2017/09/10

一念発起してPHP7.0でTwitterAPIいじるPHPを書いてみた


ini_set('display_errors', true);
error_reporting(E_ALL);

を頭に入れたら、エラーの箇所がわかった。CURLだった。
で、

apt-get install php7.0-curl
service apache2 restart

これで万事解決。無事PHP7.0でTweetできましたとさ。

というわけで、地震うさぎ他、Bot達のPHP7.0化は僕のプログラム部分の問題になりましたとさ。

eregとかsplitとか使ってる気がするんだよね結構。。
そのあたりをpreg系のpreg_replaceとかあるいは動作がPHP7.0で確認できてるexplodeとかにしなきゃなのだ。

Amazon